UTM ServiceNow issue

Incident Report for ITS System Status

Resolved

The UTM ServiceNow issue has been resolved. Thank you for your patience.
Posted Sep 18, 2023 - 14:30 EDT

Investigating

UTM ServiceNow has an email outage. No emails are being received or sent by the system. We are aware of the problem and are working on it.
Posted Sep 18, 2023 - 13:19 EDT
This incident affected: Campus (UTM) and Client Support Services (ServiceNow).