Please note that the performance issues that ACORN was experiencing have been resolved.
Posted Jul 25, 2025 - 12:11 EDT
Update
ACORN continues to experience performance issues.
Posted Jul 25, 2025 - 12:00 EDT
Update
ACORN continues to experience performance issues.
Posted Jul 25, 2025 - 11:00 EDT
Update
We are continuing to investigate this issue.
Posted Jul 25, 2025 - 10:08 EDT
Update
ACORN continues to experience performance issues. Users will experience slower than usual processing times, may receive error messages, and may need to re-login. We recommend that you use one device and avoid unnecessary refreshing to reduce the load on the system.
Posted Jul 25, 2025 - 10:05 EDT
Investigating
Please note that ACORN is currently experiencing performance issues that we are working to resolve. Users will experience slower than usual processing times, may receive error messages, and may need to re-login. We recommend that you use one device and avoid unnecessary refreshing to reduce the load on the system.
Please check this website for ongoing system updates. If you have a course-related question, please contact your registrar.
Posted Jul 25, 2025 - 09:07 EDT
This incident affected: Student Web Services (ACORN).