Performance Degradation - UTSC WAN Link

Incident Report for ITS System

Resolved

The issue has been resolved and services restored. Thank you for your patience.

Ref: CHG0032766
Posted Sep 11, 2026 - 08:02 EDT

Investigating

We are tracking a degraded state on our UTSC WAN link. Due to built-in redundancy, end-users are not experiencing any network impact. Our technical teams are investigating and will share updates as quickly as possible. Thank you for your patience.
Posted Sep 09, 2026 - 08:17 EDT
This incident affected: Enterprise Networks (UTSC WAN Link).