Unplanned Outage - Electrical / Networking - 89 Chestnut

Incident Report for ITS System

Resolved

Service for 89 Chestnut appears to have been successfully restored. If you continue to experience issues, please contact the appropriate support team below:

Students, Staff, or Faculty:
Contact the Information Commons Helpdesk:
https://onesearch.library.utoronto.ca/faq/where-information-commons-help-desk

IT Administrators:
Contact JOG:
https://its.utoronto.ca/its-units/eis/hardware-infrastructure/joint-operations-group/
Thank you for your patience during this incident.
Posted May 27, 2026 - 09:47 EDT

Investigating

An unexpected electrical outage at 89 Chestnut is affecting network and power-dependent services in this area. Our technical staff are working with facilities to service as quickly as possible. We will provide updates as the situation evolves.
Posted May 26, 2026 - 12:36 EDT
This incident affected: Enterprise Networks (Departmental Networks).