Microsoft 365 Service Degradation (North America)

Incident Report for ITS System

Resolved

Microsoft has completed reverting the networking change, and service telemetry indicates that the issue has been resolved for the vast majority of users.

Microsoft is continuing to review known impact scenarios and monitor affected services to confirm full recovery across all environments.
Posted Jul 24, 2026 - 14:17 EDT

Identified

Microsoft reports that rerouting traffic has provided some relief across the affected services. Microsoft is continuing targeted traffic-routing actions while reverting a recent networking change.

Microsoft is monitoring service telemetry and working directly with impacted customers to confirm that the mitigation is effective. The configuration rollback is expected to complete by the next scheduled update, while additional options to accelerate recovery are also being evaluated.
Posted Jul 23, 2026 - 14:35 EDT

Investigating

Microsoft is investigating an issue affecting multiple Microsoft 365 services in the North America region. Users may experience intermittent access issues or reduced functionality.

Affected services include, but are not limited to:

- OneDrive: Intermittent connection issues
- SharePoint Online: Intermittent connection issues and “Something went wrong” errors
- Microsoft Teams: Degraded chat functionality, images not loading, and issues with real-time voice app and historical reporting
- Copilot Chat: Delays and failed query actions
- Microsoft 365 Admin Center: Slow performance and intermittent access to features
- Power Automate: Flows not loading
- Microsoft Loop: Pages not opening or loading
- Microsoft Purview: Slower DLP Agent response times, failures when submitting new eDiscovery and Data Security Investigation jobs, and delays processing existing jobs
- Fabric/Power BI: Issues accessing Publish to Web reports in West US, with possible intermittent delays for some users in Europe and Asia Pacific due to service dependencies

We will provide updates as more information becomes available.
Posted Jul 23, 2026 - 13:40 EDT
This incident affected: Email Systems (Microsoft 365).