Turnitin Service Alert
Incident Report for ITS System Status
Resolved
Users may have experienced slow submission/reporting times with Turnitin at approximately 12:00PM today. The issue is resolved. We apologize for any inconvenience caused.
Posted Sep 20, 2018 - 13:08 EDT
Investigating
Users may experience slow submission/reporting times with Turnitin. Turnitin is investigating.
Posted Sep 20, 2018 - 12:57 EDT
This incident affected: Academic ToolBox (Ouriginal).