Sectigo cert-manager.com not accepting new requests
Incident Report for ITS System Status
Resolved
Service has been restored
Posted Jun 16, 2020 - 10:53 EDT
Investigating
While Sectigo's cert-manager.com site has resumed operation, it is currently not accepting new requests. We await response from Sectigo support.
Posted Jun 16, 2020 - 10:00 EDT
This incident affected: Information Security (Other).