Problems connecting to Teams Meetings
Incident Report for ITS System Status
Resolved
This incident has now been resolved.

Microsoft has posted incident #TM215947:

Title: Unable to access multiple Microsoft Teams services or features
User Impact: Users may have been unable to access Microsoft Teams meetings or calls, initiate PSTN calls or access Teams Live Events.
Final status: We've monitored the environment and have validated that service has been restored.

Scope of impact: Impact was specific to calls, meetings or Teams Live Events initiated from the North America region.

Start time: Thursday, June 11, 2020, 10:00 AM (2:00 PM UTC)
End time: Thursday, June 11, 2020, 10:40 AM (2:40 PM UTC)

Preliminary root cause: High resource utilization in our North America data center's caused an issue in which users may have been unable to access Microsoft Teams services, initiate PSTN calls or access Teams Live Events.

Next steps:
- We’re reviewing our code for improved performance and potential automated recovery options to reduce or avoid similar impact in the future.
Posted Jun 12, 2020 - 11:55 EDT
Monitoring
Reports of meeting join failures have subsided and the service appears to have returned to normal. We are continuing to monitor the situation.
Posted Jun 11, 2020 - 11:53 EDT
Investigating
There have been reports of problems joining Teams meetings. Meetings currently in session continue to work but new attendees or meetings fail. We are investigating.
Posted Jun 11, 2020 - 10:29 EDT
This incident affected: Email Systems (Office 365).