UTSC home page degraded performance.
Incident Report for ITS System Status
Resolved
Full service to the UTSC Home Page has been restored. We apologize for the inconvenience.
Posted Jul 13, 2018 - 17:31 EDT
Investigating
UTSC home page is currently experiencing a degraded performance.
Support staff at UTSC are currently working towards a full resolution.
Posted Jul 13, 2018 - 16:37 EDT
This incident affected: Web Services (UTSC Home Page).