Team Up issue
Incident Report for ITS System Status
Resolved
This incident has been resolved.
We apologize for the inconvenience and thank you for your patience.
Posted Sep 30, 2022 - 13:07 EDT
Investigating
Please note that the "Team Up!" is currently experiencing service interruption.
Support staff are working to restore service as soon as possible. We will provide updates as they become available.
Posted Sep 29, 2022 - 13:55 EDT
This incident affected: Academic ToolBox (Other).