Self-Service Password Reset (SSPR) unavailable
Incident Report for ITS System Status
Resolved
Self-Service Password Reset (SSPR) is now available.
We apologize for the inconvenience and thank you for your patience.
Posted May 12, 2020 - 11:47 EDT
Identified
Please be advised that Self-Service Password Reset (SSPR) is currently unavailable.
The problem has been identified and is being resolved a quickly as possible.
Posted May 12, 2020 - 10:39 EDT
This incident affected: Identity Management Systems (Password Change / Reset / Secret Activation Key (SAK)).