Scheduled LISTSERV Upgrade Service Interruption

Incident Report for ITS System Status

Resolved

The LISTSERV upgrade as been completed and all services have been restored. Thank you for your patience and cooperation.
Posted Jun 13, 2025 - 16:11 EDT

Update

We are currently investigating a performance issue affecting the LISTSERV service. Some users may experience delays when sending or receiving messages. ITS is actively working with the software vendor to identify and resolve the issue as quickly as possible.

We will continue to share updates on the ITS System Status page as more information becomes available.
Posted Jun 13, 2025 - 08:01 EDT

Investigating

The LISTSERV upgrade service interruption has been extended in order to allow additional time to complete the migration and testing. The status will be updated as soon as the migration is complete.
Posted Jun 12, 2025 - 17:41 EDT
This incident affected: Email Systems (Listserv).