DW RDP Service experiencing degradation in service
Incident Report for ITS System Status
Resolved
The DW RDP Service issue has now been resolved.
We apologize for the inconvenience caused.
Posted Mar 17, 2020 - 10:58 EDT
Investigating
DW RDP Service experiencing degradation in service due to the number of connections. Support staff are working on extending capacity.
Posted Mar 17, 2020 - 10:02 EDT
This incident affected: VPN Services (RDP).