Turnitin.com inaccessible
Incident Report for ITS System Status
Resolved
Turnitin issue has been resolved.
Thank you for your patience.
Posted Oct 20, 2020 - 15:53 EDT
Monitoring
We believe the issue has been resolved and service has been restored.
Users may experience slowness while using the service as the system recovers.
Posted Oct 20, 2020 - 12:02 EDT
Investigating
Users accessing turnitin.com may not be able to access these services. The vendor is working towards resolving the issue.
Posted Oct 20, 2020 - 11:41 EDT
This incident affected: Academic ToolBox (Ouriginal).