Turnitin Service Alert – May 14
Incident Report for ITS System Status
Resolved
The Turnitin issue that occurred between 8:15 am to 11:00 am is resolved.
We apologize for the inconvenience and thank you for your patience.
Posted May 14, 2020 - 11:44 EDT
Investigating
Turnitin has reported a service disruption and they are investigating the issue
Check Turnitin's system status web page: https://turnitin.statuspage.io/incidents/gztqm67k3s5k
Posted May 14, 2020 - 08:59 EDT
This incident affected: Academic ToolBox (Ouriginal).