Turnitin.com degraded service.
Incident Report for ITS System Status
Resolved
The Turnitin issue has now been resolved.
Thank you for your patience.
Posted Feb 17, 2021 - 09:46 EST
Investigating
Turnitin.com is currently experiencing an unexpected service degradation. During this time, users of the service may find that they are unable to view Similarity Reports and experience slow report generation. Users accessing these services via an integration may also be impacted.

The vendor is working to resolve the issue.
Posted Feb 16, 2021 - 13:55 EST
This incident affected: Academic ToolBox (Turnitin).