Performance Degradation - WordPress Hosting on LAMP

Incident Report for ITS System

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 09:34 EDT

Update

We are continuing the investigation.
Posted Jul 10, 2026 - 17:29 EDT

Investigating

We are aware of performance issues affecting WordPress hosting on LAMP. Some users may experience slow response times or limited functionality when attempting to load certain sites. Our technical teams are investigating and working to restore to full service. Thank you for your patience.
Posted Jul 10, 2026 - 16:28 EDT
This incident affected: Web Services (LAMP Hosting Service).