URL wp.provost.utoronto.ca not available
Incident Report for ITS System Status
Resolved
wp.provost.utoronto.ca is now available.
We apologize for the inconvenience and thank you for your patience.
Posted Oct 11, 2018 - 15:57 EDT
Investigating
wp.provost.utoronto.ca is currently not available. Tech staff are working to restore service.
Posted Oct 11, 2018 - 13:31 EDT
This incident affected: Web Services (Other).