LISTSERV issue
Incident Report for ITS System Status
Resolved
The UTORlist is now operational.
We apologize for any inconvenience caused.
Posted Jul 31, 2020 - 12:58 EDT
Investigating
We are investigating reports of some users having issues accessing UTORlist.
Technical staff are investigating the issue. We will provide more updates as they become available.
Posted Jul 31, 2020 - 11:38 EDT
This incident affected: Email Systems (Listserv).