ScreenConnect Issue version 2025.4

Incident Report for ITS System Status

Resolved

UPDATE: - A patch to address the ongoing issue was provided by ConnectWise and applied yesterday evening. Upon testing this morning we can confirm that normal service has resumed.

We've been assured that this incident was an anomaly and will work with ConnectWise to ensure that this issue does not repeat.

Thank you!
Posted Jun 20, 2025 - 10:11 EDT

Investigating

Dear Colleagues,

Following the recent ScreenConnect 2025.4 release, elevating access to administrator rights is currently down.
ConnectWise is investigating and we’ll provide an update once resolved.
Posted Jun 12, 2025 - 21:57 EDT
This incident affected: Client Support Services (Other).