Some UTMail+/m365/Azure services are not reachable from UofT networks

Incident Report for ITS System Status

Resolved

The conectivity to Microsoft resources has been restored.
Posted Mar 03, 2025 - 15:22 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2025 - 14:47 EST

Update

a workaround by our upstream providers has been implemented and services are starting to resume. We continue to monitor the situation.
Posted Mar 03, 2025 - 12:46 EST

Update

Update from ORION just now:
Today around 11:45am services from Microsoft such as Outlook and Teams have become unreachable via the ORION network. Multiple constituents have reported connection issues, as well as ORION staff. We are currently investigating the cause.
Posted Mar 03, 2025 - 12:29 EST

Update

We continue to investigate issues regarding connections to m365/Azure services. Currently, there are connectivity issues from on campus networks and other networks around Canada. We will update this as we know more.
Posted Mar 03, 2025 - 12:07 EST

Investigating

UofT support is currently investigating.
Posted Mar 03, 2025 - 12:00 EST
This incident affected: Email Systems (Office 365, UTMail+).