Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 22, 2026 - 05:00 EDT
Scheduled
Please note that the systems below will be unavailable on Saturday, August 22, from 5 a.m. to 12 p.m., due to system maintenance:
• Academic Administrative Appointments (AAA) • AMS SAP GUI • Capital Projects Portal • Concur (posting claims to AMS and progressing the workflow will resume once AMS is back online. Concur itself will be available 24/7) • Employee Self-Service (ESS)/Manager Self-Service (MSS) • EvoSuite Applications (EvoOrder, EvoPlan, EvoNotify) • Fiori Launchpad Reporting • Invoice Workflow • My Customer Account • My Research (MR/Portal) • SAP Asset Manager Mobile (sync will not work) • uSOURCE (Requisition, Purchase Order and Invoice workflows will resume once AMS in back online. uSOURCE itself will be available 24/7)
Posted Aug 04, 2026 - 14:54 EDT
This scheduled maintenance affected: Administrative Web Services (Academic Administrative Appointments (AAA), Capital Project, ESS, EvoSuite Apps, Invoice Workflow Solution (IWS), My Research (MR), MSS, uSOURCE) and AMS (AMS SAP GUI).