Partial Service Disruption - shared calendars in Outlook

Incident Report for ITS System

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 15:59 EDT

Monitoring

Microsoft has implemented a server-side fix and indicated that the issue is now resolved on their end. We are monitoring service recovery to confirm that functionality is fully restored. Microsoft is preparing a root cause analysis (RCA) and will provide it when available.
Posted Apr 13, 2026 - 14:39 EDT

Identified

Multiple users are experiencing synchronization lag issues with shared calendars in Outlook for desktop and Outlook on the web, where users are unable to view the Calendar items as a delegate view of Manager’s Calendar. Support teams are working with the vendor to resolve the issue.
Posted Apr 08, 2026 - 16:53 EDT
This incident affected: Email Systems (Microsoft 365).