Network issues at Wilson Hall and Wetmore Hall locations due to power outage
Incident Report for ITS System Status
Resolved
This incident has been resolved.
We apologize for the inconvenience and thank you for your patience.
Posted Jan 11, 2022 - 17:01 EST
Investigating
There are network interruptions at Wilson Hall and Wetmore Hall locations due to power outage.
We will provide more updates as they become available.
Posted Jan 11, 2022 - 15:13 EST
This incident affected: Enterprise Networks (Departmental Networks).