Unplanned Outage - Network - wireless - St. George Campus

Incident Report for ITS System

Resolved

The campus wireless service appears to have been successfully restored.
Posted Jun 03, 2026 - 11:46 EDT

Monitoring

The enterprise networking team has implemented a fix and are continuing to monitor the situation. Wireless services are restored.
Posted Jun 03, 2026 - 11:22 EDT

Investigating

We are receiving reports about wireless issue on St George campus. You may experience a loss or degraded or a loss of connectivity. Technical teams are actively investigating and working to restore service. We will provide updates as the situation evolves.
Posted Jun 03, 2026 - 11:04 EDT
This incident affected: Enterprise Networks (Campus Wireless Network).