UTORcsi File Server Cluster Services Degraded

Incident Report for ITS System

Resolved

This incident has been resolved.
Posted May 13, 2026 - 23:36 EDT

Investigating

Some services hosted on the UTORcsi file server cluster are currently unavailable due to a recent data center outage. We are currently investigating.
Posted May 13, 2026 - 22:25 EDT