Degraded Microsoft 365 services affecting email and admin portals

Incident Report for ITS System

Resolved

Service Restored – Microsoft has confirmed that the previously affected service infrastructure has returned to a healthy state and is operating as expected. Service availability has stabilized, and impacted Microsoft 365 services should now be functioning normally.

We will continue to closely monitor Microsoft’s remediation actions and overall service health to ensure ongoing stability. If users experience any residual issues, clearing local DNS caches or temporarily lowering DNS TTL values may help expedite recovery.

Further updates will be provided if necessary.
Posted Jan 23, 2026 - 09:24 EST

Investigating

Microsoft is investigating a potential issue impacting multiple Microsoft 365 services, including Exchange Online/Outlook. Reports indicate mail delivery delays or failures for messages sent from external senders.
Microsoft has acknowledged the issue publicly and is continuing its investigation. (MS reference: MO2121364, posted Jan 22, 2026).

Some of the impacted service functions include, but are not limited to:
- Sending and receiving email through Exchange Online;
- Listserv and Enterprise Service Center notifications;
- Emails sent from external services (e.g., Gmail, third-party platforms) are not being received by users;
- Microsoft 365 admin portals;

The M365 Admin Team is monitoring the situation closely and awaiting further updates from Microsoft.
Posted Jan 22, 2026 - 15:52 EST
This incident affected: Email Systems (Listserv, Microsoft 365, UTMail+).