Wireless Network Issues
Incident Report for ITS System Status
Resolved
The wireless network issue has been resolved and services have been restored.
Posted Apr 17, 2019 - 14:52 EDT
Investigating
Please note that ITS has received reports of service interruption affecting the Wireless network. We are investigating the reports.

Updates will be posted as they become available.
Posted Apr 17, 2019 - 14:38 EDT
This incident affected: Enterprise Networks (Campus Wireless Network).